Tello ffmpeg認識できない件

最近子供がちょっとプログラミングに興味があるようなので、会社で催されたロボットカーをスクラッチで動かす会に行ってみたりしてます。家でも遊べるようになにか買おうと思ったのですが、すぐ物足りなくなるのは嫌なので良いものないかと探していたら…

DJIのTelloというドローンが、スクラッチやPythonでコントロールできるとのことで、早速購入して、Python環境を構築。

記事的にはPython2.7の物が多く、あまり変にハマるのも嫌なのでいい感じにまとまっているサイトの通りやったのですが…

最後main.pyを実行するとエラーが出て、調べるとmain.pyから呼ばれるtello.pyの中の

import libh264decoder

がエラーを起こしていました。おそらくffmpegのバージョン不整合だと思って、古いffmpegを探したり、似たような症例で困っている人の記事を読み漁ってようやく怪しい中国のサイトからzipを落としてGetしたらffmpegを使うと…

動いた!

ところが後で気づいたんですが、DJI_SDKをGithubからZIPで持ってきて解凍すると、すばり

tello_video_dll(ForWin64).zip

というZIPが入っていて、結局最初からコレ使えばよかった模様…

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA